forum.vdsworld.com Forum Index forum.vdsworld.com
Visit VDSWORLD.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


Invalid Command in POP3.DSU

 
Post new topic   Reply to topic    forum.vdsworld.com Forum Index -> Advanced Bug Reports
View previous topic :: View next topic  
Author Message
efalzon
Newbie


Joined: 03 Sep 2004
Posts: 3
Location: Brisbane, Australia

PostPosted: Fri Sep 03, 2004 3:03 am    Post subject: Invalid Command in POP3.DSU Reply with quote

Hi all,

I've just picked up VDS recently, and I'm pretty impressed with it. But I'm experiencing an intermittent problem with .DSU commands.

I'm using POP3.dsu, which I purchased with VDS 5 + Internet Suite. It has been working fine, but yesterday it started reporting an error "invalid command at line 22 of pop3.dsu" whenever I try to call the command "pop3 connect,mail.domain.com"

I notice a posting from last year reported that everything had mysteriously repaired itself. Is there a configuration setting I need to change to fix this?


Thanks,

Edward

_________________
In theory, Practice and Theory are the same.
In practice, they are different!
Back to top
View user's profile Send private message Visit poster's website
jules
Professional Member
Professional Member


Joined: 14 Sep 2001
Posts: 1043
Location: Cumbria, UK

PostPosted: Fri Sep 03, 2004 6:55 pm    Post subject: Reply with quote

Strange. I use this extensively and have never encountered this problem.
_________________
The Tech Pro
www.tech-pro.net
Back to top
View user's profile Send private message Visit poster's website
Skit3000
Admin Team


Joined: 11 May 2002
Posts: 2166
Location: The Netherlands

PostPosted: Fri Sep 03, 2004 6:58 pm    Post subject: Reply with quote

It's a strange error, since a DSU is pre-compiled and pre-checked for errors, so how could such an error exist? Rolling Eyes
_________________
[ Add autocomplete functionality to your VDS IDE windows! ]
Voor Nederlandse beginners met VDS: bekijk ook eens deze tutorial!
Back to top
View user's profile Send private message
efalzon
Newbie


Joined: 03 Sep 2004
Posts: 3
Location: Brisbane, Australia

PostPosted: Sat Sep 04, 2004 5:09 am    Post subject: Reply with quote

Okay, I'm up and running again, and I believe I have focused in on the issue:

The Command, #EXTERNAL VDSTCP50.DLL, was declared in one of my secondary DSC files, and did not appear in the primary Project.DSC file.

After putting it as the first line in the primary DSC, it was all fine. This seems to be required <i>in addition to</i> the #include pop3.dsu declarations. How come?


Edward

_________________
In theory, Practice and Theory are the same.
In practice, they are different!
Back to top
View user's profile Send private message Visit poster's website
jules
Professional Member
Professional Member


Joined: 14 Sep 2001
Posts: 1043
Location: Cumbria, UK

PostPosted: Sat Sep 04, 2004 9:01 am    Post subject: Reply with quote

#include is a compiler directive to include the .dsu file.
external (without the #) is a command to load an extension DLL.

The external command must be executed before any of the commands or functions in the .dsu are used.

_________________
The Tech Pro
www.tech-pro.net
Back to top
View user's profile Send private message Visit poster's website
efalzon
Newbie


Joined: 03 Sep 2004
Posts: 3
Location: Brisbane, Australia

PostPosted: Sat Sep 04, 2004 10:01 am    Post subject: Reply with quote

Yes, I presumed that, and had declared it at the top of the secondary DSC file, which is the only file that calls the TCP commands & functions. Apparently that isn't the right spot.

Thanks for the advices.


Edward.

_________________
In theory, Practice and Theory are the same.
In practice, they are different!
Back to top
View user's profile Send private message Visit poster's website
Serge
Professional Member
Professional Member


Joined: 04 Mar 2002
Posts: 1480
Location: Australia

PostPosted: Sat Sep 04, 2004 3:05 pm    Post subject: Reply with quote

hi edward,

great to see another aussie on the forum Smile

serge

_________________
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    forum.vdsworld.com Forum Index -> Advanced Bug Reports All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum




Twitter@vdsworld       RSS

Powered by phpBB © 2001, 2005 phpBB Group