forum.vdsworld.com Forum Index forum.vdsworld.com
Visit VDSWORLD.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


WARNING: VDS IDE is 'eating' scripts again
Goto page Previous  1, 2, 3
 
Post new topic   Reply to topic    forum.vdsworld.com Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
Dr. Dread
Professional Member
Professional Member


Joined: 03 Aug 2001
Posts: 1065
Location: Copenhagen, Denmark

PostPosted: Fri Dec 03, 2004 1:43 pm    Post subject: Reply with quote

Naaa, default seems to be that only core Windows binaries are protected. You can then enable protection for everything.

Dread

_________________
~~ Alcohol and calculus don't mix... Don't drink and derive! ~~

String.DLL * advanced string processing
Back to top
View user's profile Send private message
FreezingFire
Admin Team


Joined: 23 Jun 2002
Posts: 3508

PostPosted: Sun Dec 05, 2004 5:14 pm    Post subject: Reply with quote

How do you enable DEP?
_________________
FreezingFire
VDSWORLD.com
Site Admin Team
Back to top
View user's profile Send private message Visit poster's website
GeoTrail
Valued Contributor
Valued Contributor


Joined: 18 Feb 2003
Posts: 571
Location: Bergen, Norway

PostPosted: Sun Dec 05, 2004 8:09 pm    Post subject: Reply with quote

Right click My Computer -> Properties -> Click Advanced tab then click Settings button under Performance. Then click the Data Execution Prevention tab.
_________________
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
FreezingFire
Admin Team


Joined: 23 Jun 2002
Posts: 3508

PostPosted: Fri Dec 10, 2004 1:02 am    Post subject: Reply with quote

Cool. Thanks Smile
_________________
FreezingFire
VDSWORLD.com
Site Admin Team
Back to top
View user's profile Send private message Visit poster's website
arcray
Valued Contributor
Valued Contributor


Joined: 13 Jul 2001
Posts: 242
Location: Aude, France

PostPosted: Wed Mar 30, 2005 8:58 am    Post subject: Reply with quote

This happened to me this morning. I lost a whole load of scripts dsc & dsp from a single folder. Luckily I had backed up that folder the day before.

BUT this is a serious bug that needs fixing for the next version.





Andy

_________________
Andrew GRAY
If you don't know I am looking for work, I won't get the job.

andrewrcgray.com
Back to top
View user's profile Send private message Send e-mail
jules
Professional Member
Professional Member


Joined: 14 Sep 2001
Posts: 1043
Location: Cumbria, UK

PostPosted: Wed Mar 30, 2005 9:52 am    Post subject: Reply with quote

No bug has ever been found, and I have never been able to reproduce the problem by following any of the reported descriptions. My guess is that it is caused by some memory overwrite that occasionally occurs, possibly somewhere in the Delphi VCL. My advice given earlier was to turn on data execution prevention in Windows XP which may stop this occurring.
The problem only started to occur after the IDE was moved from Delphi 2 to Delphi 6. I am now using Delphi 2005, which seems better at detecting AVs than Delphi 6 was. But the VDS 5 IDE is still vastly more stable than the Delphi 2005 IDE, which for me puts the problem in perspective.

_________________
The Tech Pro
www.tech-pro.net
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    forum.vdsworld.com Forum Index -> Bug Reports All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum




Twitter@vdsworld       RSS

Powered by phpBB © 2001, 2005 phpBB Group