forum.vdsworld.com Forum Index forum.vdsworld.com
Visit VDSWORLD.com
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


VDS has caused an exception of class "ElistError"

 
Post new topic   Reply to topic    forum.vdsworld.com Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
Aslan
Valued Contributor
Valued Contributor


Joined: 31 May 2001
Posts: 589
Location: Memphis, TN USA

PostPosted: Fri Feb 25, 2005 4:37 am    Post subject: VDS has caused an exception of class "ElistError" Reply with quote

This error is showing up on several PC's

"VDS has caused an exception of class "ElistError"
It may be neccessary to close and restart the IDE."

This happens when running a script from the IDE at the script end (Exit)
The line is highlighted in yellow like usual but the status still says " Running..."

At this same time the VDS.exe process goes to 98% CPU usage and the only way to close the IDE is to End task from Taskmanager.

In the Event viewer it shows:

"Hanging application vds.exe, version 5.0.1.114, hang module hungapp, version 0.0.0.0, hang address 0x00000000."

This is happening on 3 PC's running XP and VDS 5.0.2.
The size of the script doesn't seem to matter as I've experienced this as little as 10 lines up to 2700 lines of code.

Any one seen this error before and/or know of a solution?
Back to top
View user's profile Send private message Send e-mail
jules
Professional Member
Professional Member


Joined: 14 Sep 2001
Posts: 1043
Location: Cumbria, UK

PostPosted: Fri Feb 25, 2005 10:33 am    Post subject: Reply with quote

I've never seen anyone here report this, so it is probably something in the script you are running, possibly related to the use of lists, judging by the error.
_________________
The Tech Pro
www.tech-pro.net
Back to top
View user's profile Send private message Visit poster's website
Aslan
Valued Contributor
Valued Contributor


Joined: 31 May 2001
Posts: 589
Location: Memphis, TN USA

PostPosted: Fri Feb 25, 2005 1:44 pm    Post subject: Reply with quote

This is happening with all scripts that use a dialog.

I have some scripts that haven't had any problems for several months but are now giving me this problem.

This started about 2 weeks ago. This also the same time a bunch uf Microsoft updates for XP and IE were released. I'm still using SP1.

I am starting to think that one of these updates might be the culprit.

I am going to load a New PC and see if I get the same results before I apply any updates.
Back to top
View user's profile Send private message Send e-mail
Aslan
Valued Contributor
Valued Contributor


Joined: 31 May 2001
Posts: 589
Location: Memphis, TN USA

PostPosted: Sat Feb 26, 2005 5:13 am    Post subject: Reply with quote

It Looks like the culprit is Adobe Acrobat Reader Update 6.0.3

I loaded a new PC today and updated it to where the other ones where prior to a large number of updates I implemented two weeks ago.

VDS worked flauwlessly.

Then I started applying new updates one-by-one testing VDS each time.
After updating Adobe Acrobat Reader to 6.0.3, VDS started failing. Even the fonts in the IDE sometimes looked wrong (weird).

As luck would have it I'm a network admin so I have a large numbers of PC's I can test with. So, to confirm my suspition I reloaded a second PC
and the result was the same.

Unfortunately, uninstalling the update doesn't fix the issue.

After some research on the web for the "EListError" it seems that whatever system file Delphi uses with the TList control was changed by the Adobe patch. It seems that Adobe doesn't back the file up to put the file back incase of an uninstall.

I don't have Delphi and I don't know what the system file is that Delphi uses for the TList control.

If anyone knows what this file might be PLEASE let me know. It would not be fun reloading 687 PC's Sad

Thanks in advance.
Back to top
View user's profile Send private message Send e-mail
jules
Professional Member
Professional Member


Joined: 14 Sep 2001
Posts: 1043
Location: Cumbria, UK

PostPosted: Sat Feb 26, 2005 9:34 am    Post subject: Reply with quote

I don't have a clue. I thought that TList is an internal Delphi object. In other words, it is part of the Delphi runtime that is compiled into every Delphi program that uses it (including the VDS IDE and runtime.) Therefore I cannot see how any external change to the system could affect it.
_________________
The Tech Pro
www.tech-pro.net
Back to top
View user's profile Send private message Visit poster's website
Dr. Dread
Professional Member
Professional Member


Joined: 03 Aug 2001
Posts: 1065
Location: Copenhagen, Denmark

PostPosted: Sun Feb 27, 2005 11:30 pm    Post subject: Reply with quote

Sounds really weird. 6.0.3 is current version, I think, so heaps of VDS systems gotta have that one
installed without any such problems....

Greetz
Dread

_________________
~~ Alcohol and calculus don't mix... Don't drink and derive! ~~

String.DLL * advanced string processing
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    forum.vdsworld.com Forum Index -> Bug Reports All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You can attach files in this forum
You can download files in this forum




Twitter@vdsworld       RSS

Powered by phpBB © 2001, 2005 phpBB Group